Metasploit渗透测试论坛

 找回密码
 立即注册

QQ登录

只需一步,快速开始

扫一扫,访问微社区

安络长矛深度安全检测系统
Metascan metasploit pro
查看: 2073|回复: 7

kali里更新完msf,结果metasploit打不开了,求指教啊

[复制链接]

6

主题

1

好友

327

积分

正式会员

Rank: 2

发表于 2015-1-19 09:12:53 |显示全部楼层
msfconsole
/usr/share/metasploit-framework/lib/zip/zip.rb:5:in `<top (required)>': iconv will be deprecated in the future, use String#encode instead.
/opt/metasploit/apps/pro/ui/lib/apps/app_presenters/base.rb:10:in `<class:Base>': uninitialized constant Apps::AppPresenters::Status (NameError)
        from /opt/metasploit/apps/pro/ui/lib/apps/app_presenters/base.rb:7:in `<module:AppPresenters>'
        from /opt/metasploit/apps/pro/ui/lib/apps/app_presenters/base.rb:6:in `<module:Apps>'
        from /opt/metasploit/apps/pro/ui/lib/apps/app_presenters/base.rb:5:in `<top (required)>'
        from /opt/metasploit/apps/pro/metamodules/firewall_egress/lib/firewall_egress/presenters/firewall_egress.rb:1:in `require'
        from /opt/metasploit/apps/pro/metamodules/firewall_egress/lib/firewall_egress/presenters/firewall_egress.rb:1:in `<top (required)>'
        from /opt/metasploit/apps/pro/metamodules/firewall_egress/lib/firewall_egress.rb:3:in `require'
        from /opt/metasploit/apps/pro/metamodules/firewall_egress/lib/firewall_egress.rb:3:in `<top (required)>'
        from /usr/lib/ruby/vendor_ruby/bundler/runtime.rb:68:in `require'
        from /usr/lib/ruby/vendor_ruby/bundler/runtime.rb:68:in `block (2 levels) in require'
        from /usr/lib/ruby/vendor_ruby/bundler/runtime.rb:66:in `each'
        from /usr/lib/ruby/vendor_ruby/bundler/runtime.rb:66:in `block in require'
        from /usr/lib/ruby/vendor_ruby/bundler/runtime.rb:55:in `each'
        from /usr/lib/ruby/vendor_ruby/bundler/runtime.rb:55:in `require'
        from /usr/lib/ruby/vendor_ruby/bundler.rb:119:in `require'
        from /usr/share/metasploit-framework/config/application.rb:10:in `<top (required)>'
        from /usr/share/metasploit-framework/lib/metasploit/framework/command/base.rb:55:in `require'
        from /usr/share/metasploit-framework/lib/metasploit/framework/command/base.rb:55:in `require_environment!'
        from /usr/share/metasploit-framework/lib/metasploit/framework/command/base.rb:81:in `start'
        from /opt/metasploit/apps/pro/msf3/msfconsole:48:in `<main>'

如文中未特别声明转载请注明出自:http://www.metasploit.cn/

6

主题

1

好友

327

积分

正式会员

Rank: 2

发表于 2015-1-19 09:17:04 |显示全部楼层
是这些更新的rb文件有语法错误吗?

6

主题

1

好友

327

积分

正式会员

Rank: 2

发表于 2015-1-19 09:44:08 |显示全部楼层
新人没人理啊

6

主题

1

好友

327

积分

正式会员

Rank: 2

发表于 2015-1-20 16:10:10 |显示全部楼层
哎,现在还是没解决,更新不成功,显示错误信息是dkpg在配置metasploit时出错

6

主题

1

好友

327

积分

正式会员

Rank: 2

发表于 2015-1-21 11:18:36 |显示全部楼层

0

主题

0

好友

16

积分

限制会员

发表于 2015-10-8 18:55:18 |显示全部楼层
比较折腾的

0

主题

0

好友

172

积分

限制会员

发表于 2016-6-1 16:23:32 |显示全部楼层
就看看,努力学习

0

主题

0

好友

7

积分

限制会员

发表于 2017-3-1 17:20:52 |显示全部楼层
同是新人,求指教
*滑动验证:
您需要登录后才可以回帖 登录 | 立即注册

QQ|Archiver|手机版|Metasploit ( 粤ICP备15008156号-1 )

GMT+8, 2017-7-21 12:59 , Processed in 0.309700 second(s), 26 queries .

Powered by Discuz! X2.5

© 2001-2012 Comsenz Inc.

回顶部