Metasploit渗透测试论坛

 找回密码
 立即注册

QQ登录

只需一步,快速开始

扫一扫,访问微社区

安络长矛深度安全检测系统
Metascan metasploit pro
查看: 1231|回复: 1

【依赖ruby】关于iOS9安装ruby错误的问题

[复制链接]

2

主题

1

好友

54

积分

正式会员

Rank: 2

发表于 2016-12-5 15:34:42 |显示全部楼层
dyld: Library not loaded: /usr/lib/libruby.1.9.1.dylib
- ]+ j; X* s. u+ B  Referenced from: /usr/bin/ruby. P. P- v% [: r, P3 r
  Reason: no suitable image found.  Did find:
. m7 F% Z/ t& K1 `; d/ F        /usr/lib/libruby.1.9.1.dylib: mmap() error 22 at address=0x00329000, size=0x00004000 segment=__DATA in Segment::map() mapping /usr/lib/libruby.1.9.1.dylib
/ S+ ]' g6 v8 K  A: Q        /usr/lib/libruby.1.9.1.dylib: mmap() error 22 at address=0x00979000, size=0x00004000 segment=__DATA in Segment::map() mapping /usr/lib/libruby.1.9.1.dylib
* O2 m; i" c1 w% L0 CTrace/BPT trap: 50 B$ m% e6 Q3 U7 D' s
以上是错误提示,大致知道就是libruby不能被加载,下面的意思不太懂。是不是不兼容?望高人指点。
5 V3 ~4 B6 ~/ @  g, L* C$ ?本人的操作系统是iOS9.0.2,机型:iPhone5s。望大神们不吝赐教,谢谢。

如文中未特别声明转载请注明出自:http://www.metasploit.cn/

2

主题

1

好友

54

积分

正式会员

Rank: 2

发表于 2016-12-5 15:35:49 |显示全部楼层
在网上有收集到python有人出现过下面的提示的问题。然后看回答是不兼容,不知道是不是这么回事。在线等。。。。。
*滑动验证:
您需要登录后才可以回帖 登录 | 立即注册

关闭

渗透测试产品上一条 /1 下一条

QQ|Archiver|手机版|Metasploit ( 粤ICP备15008156号-1 )

GMT+8, 2017-1-23 12:21 , Processed in 0.357027 second(s), 27 queries .

Powered by Discuz! X2.5

© 2001-2012 Comsenz Inc.

回顶部